Deposits due 25 September delayed
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted 20 days ago. Sep 27, 2019 - 09:41 BST
Identified
Due to operational issues deposits that were supposed to land 25 September have been delayed. We are very sorry about this and are working very hard to process them as quickly as possible. They should be in by tomorrow at the very latest.
Posted 21 days ago. Sep 26, 2019 - 10:09 BST
This incident affected: ➡️ Deposits.