Issues with Investment display
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 21:13 BST
Update
We have resolved the issue and all investors should have access to their investments
Posted Apr 06, 2020 - 21:13 BST
Identified
We are currently having issues with displaying user's investments. Our engineers are working on a fix for this.

If you need access to your investment funds please come to support and our team can process full sellouts.
Posted Apr 06, 2020 - 10:35 BST
This incident affected: 📈 Investments.