Buy orders status showing as Rejected
Incident Report for Plum Fintech
Resolved
Please note that the incident has now been resolved. The status of the buy orders was updated accordingly to reflect the progress of the orders.

We would like to once again apologize for the inconvenience we have caused.
Posted Mar 09, 2022 - 09:20 GMT
Investigating
We are currently investigating an issue affecting some Buy Orders showing under the status Rejected in the investment tracker.

Rest assured that your funds are safe in the meantime. Our Tech Team is working on it as we speak and we will notify you as soon as we get an update.

We apologize for any inconvenience caused in the meantime!

Thank you very much for your patience!
Posted Mar 07, 2022 - 15:00 GMT
This incident affected: 📈 Investments.