Messenger Functionality Down
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 08:46 GMT
Monitoring
We'd like to inform our users that Plum Messenger service has been greatly impacted by Facebook Policy changes. These changes have been taking place since March 2020 and this is the reason why we moved Plum to the iOS and Android apps. More information can be found here: https://blog.withplum.com/update-for-messenger-users/?fbclid=IwAR35DPOMTeGEV8ZXgTNxzGERQiEJiE8U9VhfBSwsMuS0bE1Lv_LURxHXgyo

Users still using Messenger alone are advised to download the Plum app from their app stores to gain access to their accounts and perform deposits/withdrawals.
Posted Nov 19, 2020 - 19:09 GMT
This incident affected: Messenger.