Potential delay on buy orders created on January 19th & 20th
Incident Report for Plum Fintech
Resolved
The issue has been identified and the fix applied by our Tech Team.

The buy order process is now fully restored. You might observe a delay of up to 2 working days in the completion of the buy orders created on January 19th and 20th.

The buy orders submitted on the other days were not affected, together with the sell orders.

We would like to apologize for the inconvenience caused.

If you have any issues or questions, please do not hesitate to reach out.
Posted Jan 21, 2022 - 17:02 GMT
Investigating
We are currently investigating an issue affecting the Buy Orders created on January 19th & 20th.

We are doing our best to restore the buy order process.

Rest assured that your funds are safe in the meantime. Our Tech Team is working on it and we will notify you as soon as we get an update.

We apologize for any inconvenience caused in the meantime!

Thank you very much for your patience!
Posted Jan 21, 2022 - 11:09 GMT
This incident affected: 📈 Investments.