Delay in processing some Sell Orders
Incident Report for Plum Fintech
Resolved
Please note that the incident has been resolved and the Sell Order process has been restored.

We would like to apologize once again for the inconvenience caused.

Shall you have any questions, please do not hesitate to reach out to our Support team.
Posted Mar 15, 2022 - 09:20 GMT
Investigating
We are currently investigating an issue affecting some Sell Orders. In the tracker and after several days, these orders remain at the first step of the process.

We are doing our best to restore the buy order process.

Rest assured that your funds are safe in the meantime. Our Tech Team is working on it and we will notify you as soon as we get an update.

We apologize for any inconvenience caused in the meantime!

Thank you very much for your patience!
Posted Mar 10, 2022 - 13:19 GMT
This incident affected: 📈 Investments.