Instant Deposit not submitting - Server Error
Incident Report for Plum Fintech
Resolved
The incident is now closed. Thank you for your patience.

The functionalities are restored.

The Instant Deposits submitted during the incident will not be deposited. We recommend waiting for the transactions to show as cancelled in the App before giving it another try.

Our apologies for the inconvenience.
Posted Jul 23, 2021 - 17:07 BST
Identified
We are experiencing a technical issue affecting the ability to submit Instant Deposits from the following banks (First Direct, Bank of Scotland, Natwest, Halifax, Lloyds, and HSBC).

We are working on restoring the functionalities as soon as possible.

In the meantime, Direct Debits are not affected.

Rest assured that your funds are always safe in the meantime.
Posted Jul 23, 2021 - 13:21 BST
This incident affected: ➡️ Deposits.