Faster Payment processing issue
Incident Report for Plum Fintech
Resolved
The incident has now been resolved from our provider's side and the new transactions are processing normally.

The statuses of the transactions in the App are in the process of being updated accordingly.

Shall you have any questions, please do not hesitate to reach out!

Once again, we would like to apologize for the inconvenience.
Posted Apr 29, 2022 - 16:19 BST
Investigating
One of our service providers is experiencing a technical issue that might affect some customers' ability to deposit money via Faster Payment (Instant Transfer) or withdraw the money to their bank account.

We would like to apologize for the inconvenience and assure you that the issue is being worked on with high priority.

It is worth noting that your funds remain safe in the meantime.
Posted Apr 29, 2022 - 12:11 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.