Delay in the settlement of Direct Debit deposits
Incident Report for Plum Fintech
Resolved
This incident has now been resolved. All the Direct Debit deposits that were estimated to complete from March 3rd to 9th are not settled.

The money is now available in your Plum Account.

Once again we would like to apologize for the inconvenience we have caused.

If you have any questions, please do not hesitate to reach out.
Posted Mar 10, 2022 - 08:42 GMT
Monitoring
The issue had been identified and delayed Direct Debit deposits from March 3rd and 4th are now settling. Please note that It can take a few hours for the process to be fully completed.

We have discovered that a part of the Direct Debit deposits that were estimated to settle on March 7th and 8th are also affected. Rest assured that they are gradually settling as well.

We would like to apologize once again for the inconvenience we have caused.
Posted Mar 09, 2022 - 09:16 GMT
Identified
We are currently experiencing a delay in the settlement of some Direct Debit deposits that were estimated to complete on March 3rd & 4th. As the issue was identified, our Tech team is working on it and the money will be in your Plum account in the following days.

Please rest assured that your money is always safe in the meantime.

We apologize for the inconvenience caused in the meantime.

Thank you very much for your patience!
Posted Mar 06, 2022 - 08:02 GMT
This incident affected: ➡️ Deposits.