Delays in transfers between pockets
Incident Report for Plum Fintech
Resolved
This incident is now resolved as Pocket-to-Pocket transfers are now fully operational and all pending transfers are completed.

Shall you have any questions, please do not hesitate to reach out.

Once again we would like to apologise for the inconvenience caused.
Posted Jun 08, 2022 - 19:00 BST
Identified
We are aware that some customers might experience a in delay in the completion of transfers between pockets due to degraded system performance from our provider.

Rest assured that the issue as been identified and is currently being worked on.

We would like to apologise for the inconvenience caused and assure you that your money is always safe in the meantime.
Posted Jun 08, 2022 - 08:42 BST
This incident affected: ➡️ Deposits.