Delay in Mutual Funds sell orders
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Apr 22, 2024 - 09:05 BST
Identified
We're aware that some customers might be experiencing a delay in completing their mutual fund sell orders.

The issue has been identified and is being worked on by our Tech team as the highest priority.

Rest assured that your funds are always safe with Plum in the meantime.

We're sorry for the inconvenience caused.
Posted Apr 19, 2024 - 09:06 BST
This incident affected: 📈 Investments.