Cash ISA Display Balance - UK
Incident Report for Plum Fintech
Resolved
The issue has been resolved and the Cash ISA balances are displayed correctly.

Rest assured, your funds are always safe with Plum.

We apologise for any inconvenience caused.
Posted Jun 28, 2024 - 11:25 BST
Identified
We're aware that some Plum customers may have Cash ISA balances that are not being displayed correctly.

We're working on resolving this issue as quickly as possible.

We're sorry for any inconvenience caused. We'd like to reassure you that your money is always safe with Plum.
Posted Jun 28, 2024 - 10:50 BST
This incident affected: Cash ISA.