Issues with Santander connection
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Nov 18, 2019 - 17:59 GMT
Monitoring
The issue has been fixed on our partner's end. Accounts should be refreshed and working over the next couple of days!
Posted Nov 11, 2019 - 18:12 GMT
Identified
We are aware of an issue impacting Santander at this time which is preventing our customers from signing up and re-linking our accounts. We are working with our aggregation partners to fix this as soon as possible.

Bear in mind, you can still manual deposit/withdraw your funds.
Posted Nov 11, 2019 - 09:37 GMT
This incident affected: 🏦 Bank Connections.