App Data Loading

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 18:58 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 18:57 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2025 - 17:55 BST

Investigating

We're aware that some users may be experiencing loading issues and slower performance with their app.

This is being worked on by our Tech team with the highest priority.

We would like to apologise for the inconvenience this may have caused.
Posted Apr 16, 2025 - 15:48 BST
This incident affected: Plum application.