Temporary Issue Affecting Automated Rules

Incident Report for Plum Fintech

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 13:23 GMT

Identified

We’re aware that some scheduled automated savings rules may not have run as intended for some customers earlier today.

Our engineering team has identified the issue and is currently working to resolve it as quickly as possible.

Apologies for any inconvenience this may cause, and thank you for your patience in the meantime.
Posted Mar 16, 2026 - 18:11 GMT
This incident affects: Depositors.