Direct Debit deposits settlement delay
Incident Report for Plum Fintech
Resolved
This incident is now considered closed. All system are back to normal and transactions are settling as expected.

If you still have issues with some of your transactions, please reach out to our support team so we can look at each specific case and inform you accordingly.

Once again please accept our apologies for the inconvenience.
Posted Jun 13, 2022 - 10:58 BST
Update
We would like to confirm that the Direct Debit deposits that were estimated to complete on June 3rd, 6th and 7th are now completed.

Some Direct Debit deposits estimated to settle on June 8th are still being distributed and the money should be in the Plum accounts in the following hours.

We continue to monitor the situation.
Posted Jun 08, 2022 - 19:39 BST
Update
We are aware that some Direct Debit deposits are still not completed. This is due to degraded performance from our provider.

We would like to assure that your money is safe and will be available shortly.
Posted Jun 08, 2022 - 08:14 BST
Monitoring
Please note that the issue was identified and fixed. The transactions' progress is resumed and the money distribution to the pockets is estimated to complete by the end of the day.

In the meantime, we will keep monitoring to make sure the situation remains stable.

Once again we would like to apologise for the inconvenience caused and assure you that your money is always safe.
Posted Jun 07, 2022 - 16:11 BST
Investigating
We are aware that some customers might experience a delay in the settlement of some Direct Debit deposits that were estimated to complete from June 3rd. Our Tech Team is on it and we will provide an update as soon as possible.

Please rest assured that your money is always safe in the meantime.

We apologise for the inconvenience caused.
Posted Jun 07, 2022 - 08:02 BST
This incident affected: ➡️ Deposits.