Direct Debit Deposit Settlement Delay
Incident Report for Plum Fintech
Resolved
The incident is now considered resolved. The affected deposits are now completed.

We would like to apologise once again for the inconvenience caused.

If you have any questions or face any issues, please do not hesitate to contact our support team.
Posted Nov 03, 2023 - 10:12 GMT
Identified
We are aware that some customers might be experiencing a delay in the settlement of their deposits. This is due to a technical issue which we are working on fixing as soon as possible.

We'd like to reassure customers that deposits will be successfully completed, but at a slower pace than usual while this issue is being fixed.

We'd like to apologise for any inconvenience caused. Please be assured that your money is always safe with Plum.
Posted Nov 02, 2023 - 08:26 GMT
This incident affected: ➡️ Deposits.