Delayed Interest Payments

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 09:21 GMT

Identified

We’re aware that some customers have not yet received their December interest payment for their interest-bearing pockets.

We'd like to reassure customers that interest payments will be successfully completed, but at a slower pace than usual.

Apologies for any inconvenience this may cause; our team has identified the issue and is actively working to resolve it as quickly as possible!

Thank you for your patience in the meantime.
Posted Jan 06, 2026 - 10:18 GMT
This incident affected: Interest credit.