App log-in issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 15:53 GMT
Investigating
We're experiencing some connectivity issues that may prevent you from logging in or taking some actions within the app.

We're working hard to restore access to the app and full functionalities as quickly as possible.

We’re sorry for any inconvenience. Rest assured that your money is always safe in the meantime!
Posted Jan 02, 2024 - 11:34 GMT
Monitoring
The issue has been identified and a fix has been applied. Plum should be working as normal for all customers.

It was a systemic issue that was quickly fixed from Plum’s side. We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologize for the inconvenience caused and to reassure you that the security of your money was never compromised.
Posted Jan 02, 2024 - 09:03 GMT
Update
We are continuing to investigate this issue.
Posted Jan 02, 2024 - 08:24 GMT
Investigating
We're experiencing some connectivity issues that may prevent you from logging in or taking some actions within the app.

We're working hard to restore access to the app and full functionalities as quickly as possible.

We’re sorry for any inconvenience. Rest assured that your money is always safe in the meantime!
Posted Jan 02, 2024 - 08:21 GMT
This incident affected: Plum application.