Plum App Unavailable
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 13:42 BST
Monitoring
All operations have gone back to normal now and we'll keep monitoring.

Thank you for your patience!
Posted Oct 22, 2021 - 13:19 BST
Investigating
We are experiencing a connection issue with the App which may be preventing you from logging in or taking some actions within the app. We are working to restore the App access and full functionalities as soon as possible. Rest assured that your money is always safe in the meantime!

We're really sorry for the inconvenience!
Posted Oct 22, 2021 - 12:51 BST
This incident affected: Plum application.