EU - Slower Withdrawal processing speed
Incident Report for Plum Fintech
Resolved
This incident has been resolved. Withdrawal processing speeds are back to normal.

We would like to apologise for any inconvenience caused.
Posted Jul 12, 2023 - 09:01 BST
Investigating
We are aware that some customers might experience slower withdrawal processing speed.

Rest assured that we are working with our Payment Provider to restore the normal service as soon as possible.

We would like to apologise for the inconvenience caused and assure you that your money is always safe in the meantime.
Posted Jul 08, 2023 - 17:29 BST
This incident affected: ⬅️ Withdrawals.