Temporary Display Issue with Investment Holdings and Order Submissions
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 18:46 GMT
Identified
The issue has been identified and a fix is being implemented.

Rest assured that your funds are always safe with Plum.

We would like to apologise for the inconvenience this may have caused.
Posted Feb 04, 2025 - 16:55 GMT
Investigating
We are aware that some users are not able to view their Investment holdings or submit orders.

The issue is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe with Plum.

We would like to apologise for the inconvenience this may have caused.
Posted Feb 04, 2025 - 16:36 GMT
This incident affected: 📈 Investments.