Delayed deposits from

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted May 05, 2025 - 16:20 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2025 - 12:03 BST

Identified

We are currently experiencing a delay in the settlement of some deposits that were originally expected to be completed on May 2nd.

Our Tech team has identified the issue and is actively working to resolve it.

Please rest assured that your money remains safe during this time.

We sincerely apologise for the inconvenience and appreciate your patience while we work to fix this.

Thank you for bearing with us!
Posted May 03, 2025 - 11:26 BST
This incident affected: ➡️ Deposits.