EU withdrawals delay
Incident Report for Plum Fintech
Resolved
This issue has now been fully resolved by our provider.

If any pending withdrawals are now showing as failed, they can be retried and should settle at a normal speed.

We apologise once more for any inconvenience and thank customers for their patience.
Posted Mar 20, 2024 - 15:55 GMT
Update
Due to ongoing updates to the SEPA payment scheme, some customers are still experiencing delays to their withdrawals in the EU, particularly if they have French IBANs. Our provider is working on fixing this urgently.

Withdrawals continue to be processed, although at a slower speed than usual.

We apologise to any EU customers affected by this and would like to reassure you that your money is always safe with Plum.
Posted Mar 20, 2024 - 10:35 GMT
Monitoring
Due to updates to the SEPA payments scheme, some customers in the EU may see delays to their withdrawals yesterday and today. The withdrawals are being processed currently and should settle shortly.

We apologise for any inconvenience and would like to reassure you your money is always safe with Plum.
Posted Mar 18, 2024 - 17:43 GMT
This incident affected: ⬅️ Withdrawals.