Delay in Cash ISA Withdrawals
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted May 31, 2024 - 07:37 BST
Identified
We're aware that some customers might be experiencing a delay in completing their Cash ISA withdrawals.

The issue has been identified and is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe with Plum in the meantime.

We apologise for any inconvenience caused.
Posted May 29, 2024 - 08:18 BST
This incident affected: ⬅️ Withdrawals.