Tracker list degraded performance
Incident Report for Plum Fintech
Resolved
This incident is now considered closed. All systems are back to normal and the Tracker list is showing the transactions.

If you still have issues with viewing your transactions in the Tracker list, please reach out to our support team so we can look at each specific case and inform you accordingly.

Once again please accept our apologies for the inconvenience.
Posted Jun 17, 2022 - 08:27 BST
Investigating
We are aware that some customers might experience an issue in viewing their Tracker list on the Investments feature. The issue has been identified and is currently being worked on by our Tech team with the highest priority.

Rest assured that your buy and sell orders are unaffected and the security of your money is not compromised.

We're really sorry for the inconvenience!
Posted Jun 14, 2022 - 15:46 BST
This incident affected: 📈 Investments.