Temporary Discovery Unavailability

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 16:39 GMT

Identified

We are aware that some users are not able to access their Investments Discovery page.

The issue is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe with Plum.

We would like to apologise for the inconvenience this may have caused.
Posted Feb 05, 2025 - 16:26 GMT
This incident affected: 📈 Investments.