Plum Interest withdrawals and deposits delays
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Apr 04, 2024 - 09:51 BST
Identified
We’re aware that some customers are experiencing delays in the settlement of their Plum Interest withdrawals and deposits.

This is due to a technical issue that we have now identified and our tech team is currently working on a fix to resolve this.

We apologise for any inconvenience and would like to reassure you that your funds are always safe with Plum.
Posted Apr 02, 2024 - 13:05 BST
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.