Potential Delays with EUR Deposits and Withdrawals

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 07:57 GMT

Monitoring

We are currently experiencing delays in the processing of EUR deposits and withdrawals. This is due to a reported issue with our payment provider. Our team is in close contact with the provider and is actively monitoring the situation to confirm the impact and restore normal service as quickly as possible.
Posted Nov 18, 2025 - 13:51 GMT
This incident affected: ➡️ Deposits and ⬅️ Withdrawals.