PIN Reset Issue Affecting some Android Users

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 17:27 BST

Investigating

We're aware that some Android customers are experiencing issues resetting their PINs.

Our team is actively working to restore full access as quickly as possible.

We apologise for any inconvenience caused, and we appreciate your patience.
Posted Oct 24, 2025 - 10:04 BST
This incident affected: Plum application.