Change in US Stock trades settlement estimates.
Incident Report for Plum Fintech
Resolved
The change has been successfully implemented.

Starting on the 29th of May, all US stock trades will now settle on T+1 instead of T+2.

Thank you for your patience during this transition.
Posted May 30, 2024 - 14:55 BST
Monitoring
Please be informed of a change in stock settlement estimates.

Due to a bank holiday in the US, the US market is closed today, May 27th, 2024.

In addition, settlement estimates in the US stock market are being modified.
This means the settlement period for stock trades will change from T+2 to T+1.

As a result, trades from the 24th of May will not settle tomorrow either, but on the 29th of May.

Starting on the 29th of May, all US stock trades will settle on T+1 instead of T+2.

Thank you for your understanding.

If you have any questions about this, please do not hesitate to contact our customer support team by using ‘chat to human’ in the app or by emailing us at help@withplum.com.
Posted May 27, 2024 - 10:06 BST
This incident affected: 📈 Investments.