Backlog in Support
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 11:46 GMT
Identified
We are currently experiencing a high volume of queries in support. As a result there may be a longer wait time for a response. We do apologise for this and we hope to have it cleared in the next working day.
Posted Feb 27, 2020 - 16:18 GMT
This incident affected: 🤗 Live Support.