Buy Orders Completion Delay on Mutual Funds - UK
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Jun 04, 2024 - 11:18 BST
Identified
We're aware that some customers might be experiencing a delay in the completion of their buy orders of Mutual Funds, due to an issue impacting our funds provider.

Our provider is working to resolve this as quickly as possible.

Rest assured that your funds are always safe in the meantime.

We would like to apologise for the inconvenience this may have caused
Posted May 31, 2024 - 10:30 BST
This incident affected: ➡️ Deposits and 📈 Investments.