US Stocks Sell Order Delays
Incident Report for Plum Fintech
Resolved
This incident has been resolved and all the affected transactions have been settled.

We would like to apologise for the inconvenience this may have caused.
Posted Jan 17, 2025 - 15:17 GMT
Investigating
We are aware that some customers might experience a delay in the completion of their Stock sell orders.

The issue is being worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe in the meantime.

We would like to apologise for the inconvenience this may have caused.
Posted Jan 14, 2025 - 14:11 GMT
This incident affected: ⬅️ Withdrawals and 📈 Investments.