Combo Depositor did not Run

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 16:27 BST

Monitoring

We have started running the Combo Depositors.

We truly appreciate your patience while we work to resolve the issue.
Posted Aug 06, 2025 - 13:36 BST

Identified

We are aware that some Combo Deposits did not process as expected.

Please rest assured that we are working diligently to resolve this as quickly as possible.

We're sorry for any inconvenience caused, and we appreciate your patience.
Posted Aug 06, 2025 - 09:16 BST
This incident affected: Depositors.