Delays in sell and buy order settlements
Incident Report for Plum Fintech
Resolved
The issue has now been fully resolved. All affected buy or sell orders have been processed and settled.

We apologise again for any inconvenience caused, and thank you for your patience and understanding.
Posted Mar 12, 2024 - 16:03 GMT
Identified
We have now identified the issue with delayed orders and the team is working on a fix.

We appreciate your patience and apologise again for any inconvenience caused.
Posted Mar 11, 2024 - 10:51 GMT
Investigating
We’re aware that some investment customers are seeing delays in the settlement of sell and buy orders this morning.

This is due to a technical issue that we are currently investigating.

We apologise for any inconvenience in the meantime and would like to reassure you that your funds are always safe with Plum.
Posted Mar 11, 2024 - 09:49 GMT
This incident affected: 📈 Investments.