App loading issues

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 14:30 BST

Investigating

We're aware that some users may be experiencing loading issues and slower performance with their app.

This is being worked on by our Tech team with the highest priority.

We would like to apologise for the inconvenience this may have caused.
Posted Apr 24, 2025 - 14:25 BST
This incident affected: Plum application.