App log-in issues
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 07:42 GMT
Monitoring
The issue has been identified and a fix has been applied. Plum should be working as normal for all customers.

It was a systemic issue that was quickly fixed from Plum’s side. We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologise for the inconvenience caused and to reassure you that the security of your money was never compromised.
Posted Dec 19, 2023 - 17:01 GMT
Identified
The issue has been identified and a fix has been applied. Plum should be working as normal for all customers.

It was a systemic issue that was quickly fixed from Plum’s side. We are monitoring the situation to ensure our services continue to remain stable.

We would like to apologise for the inconvenience caused and to reassure you that the security of your money was never compromised.
Posted Dec 19, 2023 - 16:21 GMT
Investigating
We are experiencing some connectivity issues with the app which may be preventing you from logging in.

We sincerely apologise and completely understand the inconvenience this may cause but we appreciate your understanding whilst we are working on fully restoring our service.

We would also like to assure you that the safety of your money is never compromised in any way.
Posted Dec 19, 2023 - 16:01 GMT
This incident affected: Plum application.