A message for Customers investing in US Stocks on Plum
Incident Report for Plum Fintech
Resolved
This incident has been resolved.

We're sorry for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Dec 27, 2024 - 10:07 GMT
Investigating
We’re aware that our US pricing provider experienced an issue yesterday, which affected stock prices displayed in the app for that day.

This issue has now been resolved. However, prices and the percentage changes from yesterday may still appear incorrect.

We're sorry for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Dec 24, 2024 - 10:26 GMT
This incident affected: 📈 Investments.