Delay in Cash ISA Withdrawals - UK
Incident Report for Plum Fintech
Resolved
The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Oct 08, 2024 - 14:59 BST
Investigating
We're aware that some customers might be experiencing a delay in completing their Cash ISA withdrawals.

The issue is being investigated and worked on by our Tech team with the highest priority.

Rest assured that your funds are always safe with Plum.

We apologise for any inconvenience caused.
Posted Oct 04, 2024 - 07:34 BST
This incident affected: ⬅️ Withdrawals and Cash ISA.