EU Direct Debit Deposits Delay

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 16:02 GMT

Identified

We're aware that some of our customers in the EU region might be experiencing a delay in the settlement of their direct debits.

We’d like to reassure customers that all deposits are expected to be successfully completed on Monday and apologise for any inconvenience caused.

Please be assured that your money is always safe with Plum.
Posted Dec 31, 2025 - 11:53 GMT
This incident affected: ➡️ Deposits.