Withdrawals delayed

Incident Report for Plum Fintech

Monitoring

We have identified the issue affecting some withdrawals, and our payment partner has now restored normal Faster Payments processing.
New withdrawal requests should now be processed without delays.
If your withdrawal was submitted while the issue was ongoing and is still pending, there's no need to retry or submit a new request. Our team is actively working to process these outstanding withdrawals as quickly as possible.
We apologise for the inconvenience
Posted Jul 28, 2026 - 09:44 BST

Identified

We are currently aware of an issue affecting some withdrawals.
Our payment partner is experiencing delays with Faster Payments processing, which may cause some withdrawals to remain pending for longer than usual.
We are actively monitoring the situation and working with our provider to restore normal service as quickly as possible.
There is no need to retry or resubmit your withdrawal. Any pending withdrawals will remain in the queue while the issue is being investigated.
We apologise for the inconvenience and will provide further updates as soon as we have more information.
Posted Jul 27, 2026 - 18:51 BST
This incident affects: ⬅️ Withdrawals.