Plum app unavailable
Incident Report for Plum Fintech
Resolved
This incident has now been resolved. Thank you for your patience!
Posted Jul 20, 2021 - 11:38 BST
Monitoring
The issue was ongoing from 10.15 am GMT until 10.56 am GMT. All operations have gone back to normal now and we'll keep monitoring.

Thank you for your patience!
Posted Jul 20, 2021 - 11:18 BST
Investigating
We are experiencing a connection issue with the app which may be preventing you from logging in or taking some actions within the app. We are working to restore the app as soon as possible. Your money is always safe in the meantime!

We're really sorry for any inconvenience!
Posted Jul 20, 2021 - 11:13 BST
This incident affected: Plum application.