Delays in EUR direct debit deposits

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 09:48 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2025 - 07:52 GMT

Identified

The issue has been identified, and we are awaiting a fix shortly.
Posted Mar 02, 2025 - 11:07 GMT
This incident affected: ➡️ Deposits.