NVIDIA Corp trading restriction
Incident Report for Plum Fintech
Resolved
The incident has been resolved.

NVIDIA Corp trading is re-enabled.

We apologize for any inconvenience this may have caused.
Posted Jun 13, 2024 - 11:30 BST
Identified
We're aware that customers holding NVIDIA Corp (NVDA) shares are experiencing a discrepancy in the holding of their shares.

This was caused by an unforeseen technical issue when the stock split for NVIDIA was actioned today. The issue is currently addressed by our tech team with the highest priority.

In order to resolve this issue in the shortest possible time, NVIDIA Corp trading will be restricted. As soon as the issue is resolved, trading will resume.

We would like to apologise for the inconvenience this may have caused. Rest assured that your funds are always safe in the meantime.
Posted Jun 10, 2024 - 17:23 BST
This incident affected: 📈 Investments.