A message for Customers investing in US Stocks on Plum
Incident Report for Plum Fintech
Resolved
This incident has been resolved.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 29, 2024 - 07:21 BST
Update
We are aware that there are still some discrepancies with certain US Stocks prices.

Our team is actively working on this, and we expect to have the issue fully resolved as soon as possible.

We apologize for any ongoing inconvenience and appreciate your patience. Please be assured that your money and investments are always safe with Plum.
Posted Aug 23, 2024 - 16:01 BST
Monitoring
A fix has been implemented and we are monitoring the results.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 23, 2024 - 10:24 BST
Investigating
We’re aware that some stock prices are not displaying correctly in the app at the moment.

We’re currently investigating this and aim to resolve the issue as soon as possible.

We're sorry for any inconvenience caused. Please be assured that your money and investments are always safe with Plum.
Posted Aug 19, 2024 - 16:05 BST
This incident affected: 📈 Investments.