Easy Access Interest Pockets - Withdrawal Delays - UK

Incident Report for Plum Fintech

Resolved

The incident has now been resolved.

All affected transactions have been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted Oct 16, 2024 - 10:21 BST

Monitoring

All affected transactions have been processed and settled. We are monitoring the results.

Once again, we apologise for any inconvenience this may have caused.

Rest assured your money is always safe with Plum.
Posted Oct 15, 2024 - 08:45 BST

Investigating

We are aware that some customers may experience a delay in the settlement of their withdrawals from their Easy Access Interest Pockets.

We’re working as quickly as possible to resolve the issue.

Please be assured that your money is always safe with Plum.

Apologies for any inconvenience caused.
Posted Oct 15, 2024 - 07:50 BST
This incident affected: ⬅️ Withdrawals.