Issues affecting new users on app version 3.67.0

Incident Report for Plum Fintech

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 08:35 BST

Identified

We’re investigating an issue affecting users who downloaded the latest app version (3.67.0). Our team is working on a fix and we’ll share updates soon.
Posted Apr 07, 2026 - 17:49 BST
This incident affected: Application interface.