Plum Interest (MMF) withdrawal delays
Incident Report for Plum Fintech
Resolved
The incident has been fully resolved.

All affected transactions have now been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted May 31, 2024 - 10:05 BST
Update
The incident has been fully resolved.

All affected transactions have now been processed and settled.

Once again, we apologise for any inconvenience this may have caused. Rest assured your money is always safe with Plum.
Posted May 31, 2024 - 10:04 BST
Identified
Our team has since identified the issue, and is working on a fix.

All affected Plum Interest (MMF) withdrawals will now be completed by the end of Friday, 31 May.

Rest assured, your funds are always safe with Plum. We apologise for the inconvenience this has caused.
Posted May 29, 2024 - 12:26 BST
Investigating
We’re aware that some customers are experiencing delays in the settlement of their Plum Interest (MMF) withdrawals.

Our team is working on identifying and resolving the issue as soon as possible.

We apologise for any inconvenience and would like to reassure you that your funds are always safe with Plum.
Posted May 28, 2024 - 18:22 BST
This incident affected: ⬅️ Withdrawals.