Delayed deposits due to Migration
Incident Report for Plum Fintech
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 12:18 GMT
Identified
We are currently in the process of migrating users to our new banking provider. As a result, deposits are taking a little longer to process and MAY be delayed by a couple working days. We do apologise for this.

Luckily once the migration period is over everything will resume as normal, but now with deposits taking 3 days instead of 4 and withdrawals will now be processed more quickly 24/7!
Posted Dec 02, 2019 - 10:00 GMT